google map v3


Warning: Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /home/patareru/www/patareru/wp-content/plugins/ultimate_ga_1.6.0/ultimate_ga_1.6.0.php on line 524

googlemap api v3は

keyの取得がいらない

優れものだがストリートviewに対応したようだ。

以下サンプル。

googlemap api v3会社案内サンプル

googlemap IEで表示されない


Warning: Use of undefined constant user_level - assumed 'user_level' (this will throw an Error in a future version of PHP) in /home/patareru/www/patareru/wp-content/plugins/ultimate_ga_1.6.0/ultimate_ga_1.6.0.php on line 524

IEとgooglemapの相性が悪いのかfairefoxで表示されてIEで表示されない場合がある。
自分の場合は charset=”utf-8″ でいけました。
<script src=”http://maps.google.com/maps?file=api&v=1&key=…..” type=”text/javascript” charset=”utf-8″></script>

iframeを使う、CSSのid名を変更するなどいろいろある。以下参考
Google Maps APIと文字コード

Google Maps API を UTF-8 以外で使用する

野菜小屋の地図をGoogle Maps APIで作ってみるテスト インターネットサイト ~ は開けません。操作が中断されました

IEでは、tableの中でGoogleMapsは表示されない

GoogleマップとIEの「開けません。 操作は中断されました」

Google MAPS APIの単純な例 iframe

Google MapsがIEで表示できない

googlemap API v3を使ってみるのも手かもしれない。